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File geodatabases 
ArcGIS can directly use or import most GIS file formats in common use for geo
processing and display. The recommended native file format for use in ArcGIS 
for Desktop is the file geodatabase. It sto11es map layers, dat a tables, and other 
GIS file types in a system folder that has the suffix extension .gdb in it s name. 
In this chapter you learn about working with file geodatabases. 
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Learning objectives 

• Build file geodatabases • Join tables 

• Use ArcCatalog utilities • Aggregate data 

• Modify attribute tables 

Tutorial4-1 

Building a file geodatabase 
A file geodatabase is quite simple and flexible, being merely a collection of files in a .,.-:-----
file folder. Nevertheless, a file geodatabase provides a powerful structure and orga-
nization for spatial data. You need a special utility program to build and main
tain a file geodatabase, ArcCatalog, which you use next. Some of the functionality 
of ArcCatalog is also available in ArcMap's Catalog window. The Catalog window 
allows you to do most data utility work while in ArcMap without opening the sepa
rate application program, ArcCatalog. 

pen rcCatalo 

1 On the Windows taskbar, click Start > All Programs > ArcGIS > ArcCatalog 10.1. 

2 Click the Connect To Folder button ~ on the Standard toolbar, expand the folder and 
file tree under Computer for E!lriPress, click the GISTl folder icon to select it, and click 
OK. The Connect To Folder button is important to remember. It sets roots for the folder 
and file tree that you use in Arc Catalog, providing access to files. 

Create new fil geo ataba e 

While fi le geodatabases are only folders, you must create them using ArcCatalog or Catalog. 
Windows Explorer or Computer, while capable of creating a folder, cannot build a file 
geodatabase. 

1 In the Catalog Tree panel, expand Folder Connections, EsriPress > GISTl, and the 
My Exercises folder. ,.----- c:o.-IPre.-1 ~I 

8 ~ g '='""'GISTl ..:I ....... I TyPe 

2 Click the Chapter4 folder to display its 
contents (now empty) in ArcCatalog's 
right panel. 

:;; 0 Na;IS 
e 0 MyAS'llgnmonts 
E 0 MyExerdseS 

a; 0 Cha;>terl 
e 0 Cha;>terto 
10 0 0\aptel l 
Ill 0 Cha;>ter2 
!E E:l 01apber3 

e d>acX!r4 
"' 0 Cha;>terS 
r4o1 P'\ rh••"~ 
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GIS TUTORIAL 1 File geodatabases CHAPTER 4 

3 Right-dick Chapter4 in the left panel and click New > File Geodatabase. 

4 Change the name from New File Geodatabase.gdb to Chapter4.gdb. ArcCatalog creates 
a file geodatabase that you can populate with feature classes, stand-alone tables, and other 
objects. Feature classes are map layers stored in a geodatabase. 

Next, you import map layers in shapefile format into your new file geodatabase as feature 
classes. 

Import shapefile 
A shapefile is an older Esri file format that many spatial data suppliers still use for 
distributing map layers. ArcCatalog allows you to import shape files and other map layer 
formats into a file geodatabase. 

1 In the ArcCatalog's right panel, right-dick Chapter4.gdb, click Import > Feature Class 
(multiple). The multiple import option provides the convenience of importing several 
feature~ at the same time as well as automatically naming output feature classes with the 
shapefiles' names. 

2 In the Feature Class to Geodatabase (multiple) dialog box, click the browse button to 
the right of the Input Features field, browse to Data > MaricopaCounty, double-dick to 
open that folder, hold the SHIFT key down, and select tl_2010_04013_cousublO.shp 
and tl_2010_04013_tract10.shp. 

3 Click Add. That action adds tl_2010_04013_cousublO.shp and tl_2010_04013_tractl 0. 
shp to the input panel. 

.:j fl •, tlun· Ck1~~ lo l;cod .Jta!M~< : (multiple) ~ 
-~- - --- - - - -

Input features 

C :\Esrll'ress\GJSTl\O~tli\Martcop~Coun \d_2010_04013_cousublO shp 
C:\Esr1Press\GJST1 \O~tli\M~rtcop~County\tf_2010_04013_dcuo.shp 

Output Geodatllbase 

I C:\Esr1Press\GlSTl\MyE)(IIrclses\Chepter4\Cilapter4.gdb 

_Jol xl 

~ 

OK CaiiCII!I EnvfroiiiiM!nts. .. l Show Help » I 
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4 Click OK. ArcCatalog imports the shapefiles into the file geodatabase. 

5 In the Catalog tree, expand the Chapter4 folder and Chapter4.gdb to see the imported 
feature classes. 

or a ata tab e 

Next, you import a data table with some 2010 census data at the tract level for Maricopa 
County, Arizona. 

1 Right-dick the Chapter4 file geodatabase, then click Import> Table (single). 

2 In the Table to Table dialog box, click the browse button to the right of Input 
Rows, browse to the Data > Maricopa County folder, click CensusData.xlsx > Add > 
CensusData$ > Add. 

3 Type CensusData in the Output Table field. Notice the Field Map pane listing the data 
fields that are imported. 

·,, J,!hh•to ,,,hit·__ _ ___ _ · ~ : .. · 

Input Rows 

I C:\ESRIPreSi\GISTl \DDili\MerlcopeCounty\CensusDelll.xlsx\CensusDem$ 

output lDClltlon 

I C: \ESRIPreSi\GISTl \Myeurdses\Chepter4\Chepter4.gdb 

_lo!~ 

.;. 
~ 

~ 
~Tebte .~------------1 CensusDall! Ill""'" -
Elq)resslon (opUonel} 

Reid Map (oplklnal) 

1!1 GEOid2 {Double} 
IB PopToll!l (Double) 
8 PopWhlte (Double) 
1!1 PopNettve (Double) 
1!J PopHispanlc (Double) 
ffi PC!ncome (Double) 
ltl Whti'Clncome (Double) 
!fl NetPC!ncome (Double) 
til HlspPC!ncome (Double) 

4 Click OK. 

~ 

~ 
~ 
_!] 

.±J~ 
I! OK n cancel Environments. .. ! S'-Help» I 
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Tutorial 4-2 

Using ArcCatalog utilities 
Now that you've created a file geodatabase, you can start using ArcCatalog's utilities. 
First is Preview, which gives you a good overview of a feature layer or table. 

1 If necessary, click Chapter4.gdb in the 
Catalog tree to expose its contents in 
the right panel. 

2 In the right panel, click 
t1_201 _04013_cousub10 and 
click the Preview tab. ArcCatalog 
previews the map layer's geography. 

3 At the bottom of the Preview window, select 
Table as the Preview. Arc Catalog previews the 
map layer's attribute table. 

Contsnts I PreVIew I Oestnpllon I 
Name I Type 
IDl CensusData Fie Geodatabase Table 
!Sl11_2010_04013_cousub10 Fie Geodatabase Feature Class 
II1ll ll_2010_04013_tract10 Fie Geodatabase Feature Class 

OBJECTIO" Shape• STATEFP10 GEOID10 NAME10 I 
1 Polygon 04 0401390459 
2 Polygon 04 0401390561 
3 Polygon 04 0401390867 
4 Polygon 04 0401391377 
5 Polygon 04 0401392601 
6 Polygon 04 0401393009 
7 Polygon 04 0401393060 
8 Polygon 04 0401393472 

• 9 Polygon 04 0401393774 

4 Click the Description tab. ArcCatalog 
previews the map layer's metadata in a 
report format. For TIGER maps, only 
general metadata is available. 

5 Click the Contents tab. 

Buckeye 
Chandler 
Deer Valley 
G1la Bend 
Phoemx 
St Johns 
Salt River 
Tonto Wat1onal Forest 
Wickenburg_ 

Description 
The TIGER/Line Flies are shapeflles and related 
database flies (.dbf) that are an extract of 
selected geographic and cartographic Information 
from the U.S. Census Bureau's Master Address 
File I Topologically Integrated Geographic 
Encoding and Referencing {MAFm GER) Database 
(MTOB). The MTDB represents a seamless national 
f ile with no overlaps or gaps between parts, 
however, each TIGER/Line File Is designed to 
stand alone as an Independent data set, or they 
can be combined to cover the ent ire nation . 
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YOUR TURN 
Preview tl_2010_04013_tract10 and CensusData. 

Ren me feat re layers 
" Because a file geodatabase has a special file format, you must use Arc Catalog for file -

management purposes, including renaming and copying items. 

1 In the left panel under Chapter4.gdb, r ight-click tl_2010_04013_cousub10, click 
Rename, type Cities, and press the TAB key. 

2 Repeat step 1 to rename CensusData to be CensusTractData, and tl_2010_04013_ 
tractlO to be Tracts. 

Copy a d delete feature layers 

1 In the left panel under Chapter4.gdb, right-click Cities, click Copy, right-click 
Chapter4.gdb, click Paste > OK. ArcCatalog creates the copy, Cities_1. 

2 Right-click Cities_1, and click Delete > Yes. 

YOUR TURN 
Open a Computer window, browse to Chapter4.gdb in the Chapter4 folder of My Exercises, 

right-click Chapter4.gdb to get its proper ties and size, and take a look at the files inside of 
it comprising the cities, tracts, and census tract data. You should find that the folder size is 
approximately 1.5 MB on the disk and that its 55 files are incomprehensible. You need ArcCatalog 
or Catalog in ArcMap to use, manipulate, and understand these files. Leave the Computer 

window open for use in the following steps: 
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l~HAPTER 4 

Compress a file geodatabase 

1 In the left panel of ArcCatalog, right-click Chapter4.gdb, click Administration > 
Compress File Geodatabase >OK. 

2 Use a Computer window to check the size of the Chapter4.gdb folder. Verify that the 
compressed file geodatabase is a little less than 1 MB on the disk, about a 40 percent 
reduction in size. 

While ArcMap can process compressed feature layers by uncompressing them on the fly, 
you will use the next step to uncompress the folder and get the layers back to original size. 

3 In the left panel, right-click Chapter4.gdb, click Administration > Uncompress File 
Geodatabase > OK. 

4 Close ArcCatalog. 

YOUR TURN 

Open Arc Map and create a new map document called Tutorial4-3.mxd with relative paths 
stored in the Chapter4 folder of MyExercises. Add the two layers and table from Chapter4.gdb 

and symbolize as seen in the following. Save your map document. 

l..ilyers 
=' C:\ESrl'ress\GISTl \M'(Ex~ 

a li!l 01es 
c 

3 li!l Tracts 
C) 

lEI CensusTractData 
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Tutorial 4-3 

Modifying an attribute table 
Most of what gets processed or displayed in a GIS depends on attribute table 
values. There is much, therefore, that you need to know about working on tables, 
including deleting, modifying, and creating columns. 

elete unnee ed co um s 

Many map layers have extra or unnecessary attributes, from the user's point of view, that 
you can delete to tidy up. 

1 In the table of contents, right-dick Tracts and click Open Attribute Table. It's not 
possible to delete the primary key created by ArcGIS, ObjectiD, or the Shape attribute. 
GEOIDlO is the tract geocode that you need for joining the CensusTractData table to the 
tracts map layer, but all other fields are candidates for deletion. 

2 In the table, right-dick the header for the STATEFPlO column, click Delete Field, and 
click Yes. 

3 Similarly delete the following fields: COUNTYFPlO, TRACTCElO, NAMElO, 
NAMELSADlO, MTFCClO, and FUNCSTATlO. 

4 Close the Tracts table. 

YOUR TURN 
GEOIDlO is a unique city identifier in the United States. Delete fields from the Cities layer 

to keep just OBJECTID, Shape, GEOIDl O, NAMElO, Shape_Length, and Shape_Area. When 
finished, close the Cities table. 

o ify a geocode 

It is often necessary to join two tables to make a single combined table. For example, there 
are thousands of census variables, so it is impractical to have all needed census variables 
for tracts stored in the Tracts att ribute table. Instead, you select the variables you wish, 
download a corresponding table (which includes tract geocodes) from the Census Bureau 
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website, and join the table to the tract polygon table by geocode. The GEOID10 column 
of the Tracts attribute table and the GEOid2 column of the CensusTractData table are 
the corresponding geocodes for these tables. These attributes would match, except that 
GEOID10 has a text data type while GEOid2 has a numeric data type. You can tell because 
text data is left-aligned in its column while numeric data is right-aligned. 

1 In the table of contents, right-dick CensusTractData, click Open, and sort GEOid2 
ascending. You can see that this numeric attribute's first sorted value is 4013010101. 

2 Close CensusTractData. Similarly, open the Tracts attribute table and sort GEOIDlO 
ascending. The first sorted value is the text value 04013010101, with a leading zero, but 
otherwise matches the geocode in CensusTractData. 

To get this table's geocode to join with that in CensusTractData, all you have to do is create 
a numeric version of it, which is easy with the Field Calculator. The numeric version drops 
the leading zero. 

3 In the Tracts table, click the Table Options arrow an\:1 click Add Field. 

4 In the Fields dialog box, type GEOIDlONum in the Name field, change the Type to 
Double, and click OK. You need Double, which can have values up to 15 digits in length, to 
store GEOID10. 

5 Right-click the GEOIDlONum header and click Field Calculator > Yes. 

6 In the Field panel, double-click GEOIDlO (to set GEOIDlONum = GEOIDlO), and click 
OK. That provides the needed geocode for joining the CensusTractData table to the Tracts 
attribute table. 

7 Close the Tracts table and open the CensusTractData table. 

Before making the join, first you create some new calculated columns in the 
CensusTractData table needed for a map document. 

Ca cu t a colu 

The Census Data table has popu ation and per capita income for the total population, 
whites, Native Americans, and Hispanics. Desired for mapping are two ratios of per capita 
incomes for Native Americans divided by whites and for Hispanics divided by whites. 

1 In the CensusTractData table, click the Table Options arrow and click Add Field. 

-
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2 In the Add Field window, type RNatWht in the Name field, change the Type to Float, 
and click OK. 

The new column will contain the ratio of Native American per capita income to white per 
capita income. Wherever this ratio is greater than one, Native Americans on average earn 
more than whites. First, however, you must select only records where PCincWht is greater 
than zero, because PCincWht is the divisor for this ratio and is used to calculate values for 
RNatWht. Anything divided by zero is undefined, so this case must be avoided; this is done 
through the selection. 

'lr 3 In the CensusTractData table, click the Table Options arrow and click Select By 
Attributes. 

4 In the Select By Attributes dialog box, scroll down the list of fields, double-click 
WhtPCincome to add it to the lower Select panel, click the > Symbol button click Get 
Unique Values, and double-click 0 in the Unique Values list. Those actions create the 
expression "WhtPCincome" > 0. 

5 Click Apply > Close. 

6 Right-click the RNatWht header and click Field Calculator > Yes. 

7 In the Field Calculator window, double-click NatPCincome in the Fields panel , click the 
I button, double-dick WhtPCincome in the Fields panel, and click OK. Rows with values 
for both the numerator and denominator get data values, those with a del}ominator that is 
positive but no numerator get a zero, and those with 0 or null for the denominator retain 
the null value. 

YOUR TURN 

Repeat the previous steps to calculate a new column in the CensusTractData table called 
RHisWht, which is the ratio of HispPCincome divided by WhtPCincome. This is the ratio of per 
capita income of Hispanics divided by t he per capita income of whites. Clear the selection and 

close the table when finished. Save your map document. 
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Tutorial 4-4 

Joining tables 
Next, you will join the CensusTractData table to the polygon Tracts feature class. 
The same steps work if your map layer is a shapefzle or map layer in another format 
supported by ArcMap. 

1 Save your map document as Tutorial4-4.mxd to the Chapter4 folder. 

2 In the ArcMap table of contents, right-dick 
the Tracts layer, click Joins and Relates > 
Join. 

3 Make the selections shown in the 
image on the right. 

4 ClickO.K. 

- dop - .......... "*'..,.., 

ose-
lii~Ceopel,_. 

Al ...................................... llllle. 
_......,_... .. _ ......... l'ar .. ....,lloloog ..,...._ ..................... -

,. ..... ., ....... .... 
•• _.. .... IBrgllllllla ~-- ......... JI*I 
~ lllotr.-.1 .. ...-..... ,..,....IBrgll ..... 

5 Open the Tracts attribute table, scroll to the right in the table, and verify that ArcMap 
joined the CensusTractData table to the Attributes of Tracts table. 

6 Close the Tracts table. 
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YOUR TURN 
Now that you have census tract data attached to the census tract map layer, you can make 

a quick map of an interesting variable. Are there places in Maricopa County where Native 
Americans typically have higher per capita income than whites? Make a choropleth map using 
the RNatWht (ratio of Native American per capita income divided by white per capita income) 
attribute you created. Use quantiles for the numeric scale and the red to yellow to green color 

ramp. When finished, save your map document. 

s Layers 
li!l OII!S 
c 

a li!l Tracts 
RNatwht 

• ooooooo 
• 0.000001 - 0.393763 
• 0.393764 -0.655118 

0 655119 • I 047532 
• 1.047533 - 4.605406 
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Tutorial4-5 

Creating centroid coordinates in a 
table 

The centroid of a polygon is the point at which the polygon would balance on a 
pencil point if it were cut out of cardboard. A map layer consisting of polygon cen
troid points has many uses; for example, together, polygons and their centroids give 
you the ability to display two attributes of the same map layer in the same map, 
one as a choropleth map and the other as a size-graduated point marker map. Next, 
you use ArcMap's tool for calculating polygon centroids. 

Add x,y coor inates to a polygon at tribute table 

As a precaution and as a simplification, when you add new fields to an attribute table that 
has a joined table, it's a good idea to remove the join fi rst, create the new fields, and then 
rejoin the table. 

1 Save your map document as Tutoriai4-S.mxd to the Chapter4 folder. 

2 Right-dick Tracts in the table of contents, click Joins and Relates > Remove Joins 
> Remove All Joins. Your choropleth map disappears because the attribute that was 
displayed was in the joined table, which you just removed. 

3 Open the Tracts table, click the Table Options arrow, and click Add Field. 

4 Type X as the Name, select Double for Type, and click OK. 

S Repeat steps 3 and 4 except call the new field Y. 

6 Right-click the X header, click Calculate Geometry > Yes. Examine the Calculate 
Geometry window and click OK > Yes. 

7 Repeat step 6 except right-dick theY header and select Y Coordinate of Centroid. Close 
the attribute table when finished. 

Shape length Shape_ Area GEOID10Num X y 
0.127403 0.000755 4013422644 -111 .598551 33.366828 
0.09817 0.000499 4013422643 -1 11 .618524 33.357267 

0.063555 0.000249 4013422642 -111 .627432 33.371808 
0.132432 0.000748 4013422641 -11 1.661659 33.357603 
0.170811 0.001141 4013815900 -111 .757895 33.264 
0.075694 0.000274 4013815800 -111 .697149 33.284485 

.. 
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YOUR TURN 
Rejoin the CensusTractData table to t he Tracts layer. 

xport a table 

When you export joined tables as a table, you get all the attributes of the joined tables 
stored as one table permanently. (Similarly, if you export a map layer that has a joined 
table, the new map layer's attribute table has both tables joined permanently.) There are 
several possible uses for the new table, one of which is to use it to make a new point layer 
based on the centroid coordinates. 

1 Open the Tracts attribute table, click the Table Options arrow > Export. 

2 In the Output table field of the Export Data window, click the browse button, change 
the Save As type to File Geodatabase tables, browse to the Chapter4 folder, double-click 
Chapter4.gdb, change Name to TractCentroids, and click Save> OK> Yes. Open the 
table to see that it has all of the columns of both joined tables. Then close the table. 

3 Close the Tracts attribute table. 

Creat a feat re class from an XY tab e 

1 On the Menu bar, click Windows > Catalog. This opens a version of ArcCatalog as a 
window in ArcMap, thus providing quick access to GIS utility programs. 

2 Expand the Chapter4.gdb file geodatabase. 

3 Right-click TractCentroids, click Create Feature Class > From XY Table. 

4 In the Create Feature Class From XY Table window, click the Coordinate System of 
Input Coordinates button, click the Add Coordinate System button I "" > Import, 
browse to Chapter4.gdb, double-click Tracts in Chapter4.gdb, and click OK. 

The coordinate system's geographic spherical coordinates are the same as those of the 
Tracts layer, so the simplest option is to import the system specification from Tracts. 
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5 Click the browse button for Output, change the Save As type to File and Personal 
Geodatabase feature classes, browse to and double-dick Chapter4.gdb, change the 
Name to CensusTractCentroids, click Save > OK. 

6 Drag CensusTractCentroids from the Catalog window to the map document and drop it 
at the top of the table of contents. 

7 Close the Catalog window in ArcMap. 

8 Open the Cities attribute table, click the row selector for Phoenix to select that record 
and polygon on the map, and close the table. 

9 Right-dick Cities in the table of contents, click Selection > Zoom to Selected Features. 
Now you can get a better look at the centroids point layer you just created. 

j ~ Layel'!l 
-lu C:\E511PreSI\GISTl \MyExerdsel 

li!l censusTractCentrotds 

-1 til.ctles 
c 

- til Tracts 
0 
censusTractoata 
Tractcentrotds 

Symbolize a chorop et a centroid map 

Here you symbolize a map using both the tract polygons and centroids. Let's see how per 
~ 

capita income compares with percentage of total population that is Hispanic. 

1 In the table of contents, right-dick the Tracts layer, click Properties > the Symbology tab. 

2 In the Show panel, click Quantities > Graduated Colors. Under Fields, select 
PopHispanic for the Value field, change Normalization to PopTotal, click Classify, 
change Method to Quantile, and click OK. Change the color ramp to yellow through 
brown. 
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3 In the Symbology tab, click the Label header to the right of the Symbol and Range 
headings, click Format Labels, click the Numeric Category, change the number of 
decimal places to 2, and click OK twice. 

4 Right-click CensusTractCentroids in the table of contents, click Properties > the 
Symbology tab. 

5 In the Show panel, click Quantities > Graduated Symbols. Under Fields, change Value 
to PCincome. 

6 Change the Symbolize Size range to 2 to 10. 

7 Click the Template button, choose Circle 2, and click OK. 

8 In the Classification panel, change the number of classes to 5, click Classify, change 
Method to Quantile, and click OK. 

9 In the Symbology tab, click the Label header, click Format Labels, click the Numeric 
Category, change the number of decimal places to 0, click OK twice, and save your map 
document. Now you can plainly see that Phoenix, Arizona has areas with concentrations of 
Hispanic population, and those areas tend to be low income. 

Is Layers 
a C:\E5rf>ress\GIST1 yExerdseS 

EJ lii!l CensusTracteentrOkls 
PClncome 

. 0. 19112 
• 19113 . 29694 
0 29695 . 42067 
• 42068 • 62238 

62239. 111744 
8 lii!l Otles 

c 
El 1ii!1 Tracts 

PopHJspaniC 1 Pop Total 
D 0.00-0.09 
[:J 0.10 . 0.16 
• 0.17. 0.27 
. 0.28 · 0.49 

0.50. 0.93 
1111 CensusTractOatll 
1111 Tracteentrolds 

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight



GIS TUTORIAL 1 File geodatabases CHAPTER 4 

Tutorial4-6 

Aggregating data 
A car beat is the patrol area of a single police car. This tutorial has you count (or 
aggregate) eating and drinking businesses in Rochester, New York within car 
beats. Such businesses are crime attractors, so it is useful to have a map showing 
where they are concentrated. In this case, the workflow has four steps. First, you 
join a code table to all business points in order to identify the businesses of inter
est. Second, you apply a definition query to businesses, limiting them to eating and 
drinking businesses. Third, you use a spatial join of car beats to eating and drink
ing businesses to count them up by car beat. Finally, you use the results to create a 
choropleth map of car beats representing the number of drinking and eating places 
in each car beat. 

Join a code table to an attribute able 
. 

Here you do a one-to-many join. Earlier in this chapter, you did a one-to-one join between 
the CensusTractData table and the Tracts attribute table. Each CensusTractData record 
had one and only one matching Tract polygon and record. This time, each SIC (standard 
industrial code) record in the code table potentially has many matching records in the 
Businesses point layer; for example, all of the drinking places in Rochester for the SIC 
record for code 5813. 

1 Open Tutorial4-6.mxd from the Maps folder. The map that opens displays police car 
beats in Rochester as polygons, and all businesses as points. 

2 Save your map document to the Chapter4 folder . 
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3 Open the Businesses attribute table and examine its attributes. There are 9,325 
businesses of all kinds with the name and address of each business along with a four-digit 
SIC code. To break this code you need the code table called SIC. Notice that the SIC column 
in the Businesses attribute table has the text data type. 

1009 P01n1 
9010 Po•nl 
9011 Po1n1 

WATE!FHV19E! INC 
WATE!A 5TAE!E!f OAtLL 
WATEA 9fAE!E!f Mu91C HALL 
WA 1'E!APRO 9UFIPLIE!S COAP 
WATE!AWOAKS J WE!LLINGTON9 
WATKJN5 AOVE!ATI91NG 

' 
4 Close the Businesses attribute table. Click the List By Source button at the top of the 

table of contents and open the SIC table. This code table has two-, three-, and four-digit 
SIC codes and descriptions. The two-digit code, 01 for Agriculture, is broken down into 
three-digit categories, for example 011 Cash grains. Then three-digit codes are broken 
down into four-digit business types, for example, 0111 Wheat. Note that SICCODE also has 
the text data type, which makes the join to Businesses possible. 

Multc:altMttument ttotat 
elllng And Otink.ng F'lac:eg 
eaung and Ottnklng Pliac:e• 

1 Elling placet 
Drinking plisceg 
Milc:ellaneou9 Rlfla•l 

5 Close the SIC table. Right-dick the Businesses layer in the table of cont ents, click Joins 
and Relates > Join and t ype or make the selections shown in the graphic on the next 
page. 
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6 Click t e Validate Join button. You get 
a report that 9,253 of 9,325 business 
records successfully join. If you needed to 
diagnose and repair the non-matches, you 
could, but you skip that here. 

7 In the Join Validation window click 
Close and click OK. 

File geodatabases 
,s~ -
~ CHAPTER 4 
'' 

1 Ch®RIN fttld In lhltllytr tllo~~ln wt8 be btlld am 

''" ~- :!1 
J. ChaaR IN lllbiiiO join to IIIII ltyer, or lotd 1111 llbll ll'am diiiU 

j6i SIC 

F lhaw 1111 atlrtbuttttblll of r.ye,. In lhlslill 

J ChaaR Ill• fttld In 1111 tllllt to ~Jain an. 
jtiCCOO& '1111""'""-------:!J...,• 

.lain OpUOnl 
(f KIIP tH rtcardl 

All rt=rdlln 1111 IIIQit llblt trt .,_ In IN I'IMin9 llble, 
Unmall:hld mordl wtH c:an11111 nul ...-..sl'or t1 fttldl btlno 
tppendld Into IN lll9tlllbllll'am tilt jaln t1bl1. 

(' K11j only 1111tdii"G records 
r 1 record In t111111Q1t llbll daun~ 11M 1 1111tdlln the join 
111111, IIIII record II rtmMd 11om 1!11 rtwlllng tlf9lltlblt. 

8 Open the Businesses attribute table, scroll to the right, and see the joined SIC code 
descriptions. Of course, all irrelevant SICCODE values, including those two- and three
digit values, were ignored in the join process. Only relevant four-digit codes were used. 

9 Close the attribute table. 

Create a defi ition uery 

1 Open the Businesses layer's properties and chck the Definition Query tab. 

2 Click the Query Builder button, and build the query criterion: SIC.SICDESCR = 'Eating 
places' OR SIC.SICDESCR = 'Drinking places' using the Get Unique Values button to 
get description values. 

3 Click OK > OK. There are 457 such places now displayed. 

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight

SG14348
Highlight



File geodatabases GIS TUTORIAL 1 

Use a spatial join to count eat ·ng and drin ·ng places by 
car beat 

If you do a spatial join of a polygon layer with a point layer, the result is statistics by 
polygon for the points. Each such join automatically includes a count of points per polygon, 
and if there are quantitative attributes of the points they can have statistics included, as 
seen in the graphic for step 1. 

1 Right-click Car Beats, click Joins and Relates > Join, and make selections as follows: 

lUlU 1'.1lol --

__ .,..._.,ct_Gibllllllllllarof'•-- .. .,... """' 
far~ l)ft1bolllt 1M ..... - ... 11115-

Wllllt do.,... Willi Ill JOin 11111111 loytr1 '-

!Join -from anCI!ter layer buld on lplliOI- ::!] 

1 o-llie layer 111 J1*1 11111111 layer, or load spoaol- from dlst: 

F llustles1es ,. .:. ~ 
:z. You ""' -llll'olygont 

Selocll ,.. future doss-.-. - .... be glvon ..,tiWII 
Ojlllons based on goometry typos olllle .....,. future doss 
end 1M,.. foolln dus. 

.. Eadlpolnjon ... be 11'\'tft. """"*Y ollle Jlllnent- .. """*.,..,.._ ... and 8 -ield ._,_, pollllo .....,.. 
How do youwarwlle .-ibulet., be....,......,,..,., 

r A'l8fll98 r .... r stanc~an~a.-
rSum r rv-

r EliCh polygon .. be gowen.,.,.-"'"" pan ..... c~os 
.... ~.and .-.lield.-.g'-doo• ... pon• 
........... largellayelj. 

Nolo Apoinl-.ollSICie a polygon it hiJIOd aa bMig doses! I 
polygol\(<a.adi-.ceaiCJ). ) 

3. ,._.alllleJI*I ... bt--·-· 
Spedfy ooqut !!hlpolle or felblrldas far 11115 oww i¥r' ; 

japlltr4\Cintplllr4 gdb\C..SaauEallni)Omlangllumouu J::!..i 

"""" ..... n ()It 

2 Click OK. 

3 Remove the original car beats layer from the table of contents. 

4 Symbolize the choropleth map using the Count_ attribute of 
CarBeatsEatingDrinkingBusinesses. Use five quantiles and label each polygon with the 
Beat attribute. The result is a good, high-level map for scanning Rochester for car beats 
with many eating and drinking places. A good interactive version of this map would have 
the new layer turn off when zoomed in and the Businesses point layer turned on for details. 
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s Layers 
s li!l caraeatsEatmgD klngBusilesses 

Count_ 
0 1-3 
1!1 4-6 

7- 13 
. 14-18 

19-38 

5 Save your map document and close ArcMap. 
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Assignment 4 -1 

Investigate educational attainment 
In this assignment, you carry out all of the standard steps to work with census data in a GIS. 
Chapter 5 covers downloading and preparing data from the Census website, so this assignment 
st arts at t he point after census data is downloaded and ready for use. You create a file geodatabase, 
import a census tract map and data table into the fil~ geodatabase, carry out several data utility 
and calculation steps, join the data table to the tract map, and produce a map layout. The data is 
on education attainment in Allegheny County, Pennsylvania. Your objective is to create a layout 
comparing the fraction of males versus females 25 or older who have an associate college degree or 
higher. You can imagine that spatial patterns are similar, but is high educational at tainment the 
same for both sexes? 

Get setup 
First, rename your assignment folder and create a map document. 

• Rename the folder \ EsriPress\GIST1\MyAssignments\Chapter4\Assignment4-1YourName\ 
to your name or student ID. Store all files that you produce for this assignment in this 
folder. 

• Create a new map document called Assignment4-1YourName.mxd with relative paths. 

Use the following steps to project the table of contents layer to the state plane coordinate system, 
with coordinates in feet: . 

• Right-click Layers in the table of contents, click Properties > Coordinate System tab. 

• Expand Projected Coordinate Syste\ns, State Plane > NAD 1983 (US feet) and click NAD 
1983 State Plane Pennsylvania South FIPS 3702 (US Feet) > OK. 

Build the map 
Create a new file geodatabase called Assignment4-1YourName.gdb. Import data into it : 

• Import \EsriPress\GIST1\Data\DataFiles\tl_2010_42003_tractl O.shp as a feature class and 
rename it Tracts. GEOIDlO is the tract geocode in this table and it has the text data type. 

• Import \EsriPress\GISTl\Data\DataFiles\AllCoEdAttain.xlsx, HighEdAttainment$ 
worksheet as a table and rename it EducationalAttainment. This is 2010 census tract 
data for Allegheny County on educational attainment. Attributes include: GEOid2 = 
tract geocode, numeric data type; Female25_ =total female population 25 and older; 
FemaleAssociateDegree = female population 25 or older with an associate degree as 
highest educational attainment; FemaleBachelorDegree = female population 25 or older 
with a bachelor's degree as highest educational attainment; and so forth up through 
FemaleDoctorateDegree. Include FemaleProfessionalDegree in your calculations. Males 
have similar attributes. 
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Add Tracts and EducationalAttainment to your map document. 

Prepare Tracts for use: 

File geodatabases 

• Create a new geocode, matching the data type of the geocode in the data table. 

• Clean up the attribute table, deleting unneeded attributes. 

Create two new attributes in EducationalAttainment: 

• PCollegeF = Percentage of females 25 and older who have an associate college degree or 
higher (so values possibly could range between 0 and 100). Use Float as the data type. 

• PCollegeM = Percentage of males 25 and older who have an associate college degree or 
higher. Use Float as the data type. 

• Hint: Before calculating PCollegeF, select rows where Female25_ > 0. Otherwise you will 
get a warning message that the calculation failed (in cases where the denominator of your 
expression was zero). Do the same for males. 

Create a layout that compares the two new attributes, PCollegeF and PCollegeM. 

• Use the map layer and table in your file geodatabase (and not the shapefile or Excel table). 

• Use two data frames and two separate choropleth maps, one for each new attribute. 

• Use the same color ramp and numeric scale for both maps and include a single, common 
legend. 

Hint: Finish one data frame. Then copy and paste it for the second data frame, making 
modifications as necessary. Create a layer file for the first data frame's map and use it to symbolize 
the second data frame's map. 

Create a scatterplot of PCollegeF versus PCollegeM and add it to the layout. 

• Use View > Graphs > Create Graph to create the scat terplot. Experiment with modifying 
and improving your graph's axes (e.g., use tic marks of 20), add vertical grid lines, increase 
the sizes of fonts, etc. by right-clicking your graph and clicking Advanced Properties. 

• Once the plot is created, resize its window so that the vertical and horizontal axes are the 
same length. 

• Right-click the graph and click Copy As Graphic. On your layout, click Edit > Paste. 
Reposition and align the graph and other elements of your layout. 

• On the layout window, click Customize > Tootbars > Draw and draw a red line from (0,0) to 
(100,100) on your graph. This is the line of perfect equality of educational attainment for 
males and females. Think about the pattern you see on your maps and the graph. 

• Save your layout and export it as Assignment4-1YourName.jpg. 
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Assignment 4 -2 

Compare serious crime with poverty in Pittsburgh 
The criminology literature finds that much crime is related to poverty: the larger the population 
living in poverty, the higher the rate of certain kinds of crimes. Let's see if this relationship is 
evident in Pittsburgh at the census tract level. In the process, you'll build a file geodatabase, import 
map layers into it, build a code table from scratch anP. join it to a map layer, join census data to a 
map layer, and carry out a spatial join to aggregate data. 

Get setup 
First, rename your assignment folder and create a map document. 

• Rename the folder \ EsriPress\GIST1\MyAssignments\Chapter4\Assignment4-2YourName\ 
to your name or student ID. Store all files that you produce for this assignment in this 
folder. 

• Create an w map document called Assignment4-2YourName.mxd with relative paths. 

Use the following steps to pr ject the table of contents layer to the state plane coordinate system, 
with coordinates in feet: 

• Right-click Layers in the table of contents, click Properties > Coordinate System tab. 

• Expand Projected Coordinate Systems > State Plane > NAD 1983 (US feet) and click NAD 
1983 State Plane Pennsylvania South FIPS 3702 (US Feet) > OK. 

Build the map 
Create a new file geodatabase called Assighment4-2YourName.gdb. Import the following data into it: 

• \EsriPress\GIST1\Data\Pittsburgh\Shapefiles\PittsburghSeriousCrimes2008.shp-point 
shapefile of serious crime offense locations in Pittsburgh during summer, 2008. Attributes 
include: CCN = police ID for offense, Address = location of the offense, DateOccur = date 
of the offense, Hierarchy= FBI hierarchy code for the offense (1 = Criminal Homicide, 2 
= Forcible Rape, 3 = Robbery, 4 =Aggravated Assault, 5 = Burglary, 6 = Larceny-theft, 7 = 
Motor Vehicle Theft , 8 =Arson). 

• \EsriPress\GIST1\ Data\Pittsburgh\City.gdb\ PghTracts- polygon features of Pittsburgh 
2010 census tracts. 

• \EsriPress\GIST1\Data\Pittsburgh\Shapefiles\PovertyTracts.xlsx with PghPovertyTracts 
worksheet-2010 tract data for poverty. Attributes include: GEOid = tract geocode 
(numeric data type), PopWithPovStatus = population for whom poverty status is known 
(presumably the same as total population), PopBelowPovLevel = population who are below 
the poverty level. 

Join PghPover tyTracts to PghTracts and make a choropleth map for population below the 
poverty line. 
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Create a new code table in your file geodatabase: 

• Right-dick your file geodatabase in Catalog and click New > Table. 

• Name the table UCRHierarchy with no alias. Click Next > Next. 

• Create a field called UCR with the Short Integer data type. Create nother field called Crime 
with the Text data type and length 20. 

• Click Customize > Toolbars > Editor. 

• On the editor toolbar, click Editor > Start Editing > Continue. 

• Open UCRHierarchy in the table of contents, type 1 for UCR and Criminal Homicide for 
Crime in the first row. 

• Finish up inputting rows found with codes and crime types from the description of 
PittsburghSeriousCrimes2008.shp above. When done, click Editor in the Editor toolbar, 
Save Edits, Stop editing, and close the Editor tool bar. Close your new table. 

Create the following query definition for PittsburghSeriousCrimes2008 and rename that layer in 
the table of contents to be PittsburghSeriousCrimesSummer2008: 

"DateOccur" >=date '2008-06-01' AND "DateOccur" <=date '2008-08-31' . . 
Join UCRHierarchy to PittsburghSeriousCrimesSummer2008. Symbolize 
PittsburghSeriousCrimesSummer2008 with the Crime attribute using unique values. Use different 
shapes and colors for point markers. This layer will display only when you zoom in. 

Spatially join PittsburghSeriousCrimesSummer2008 to PghTracts to get a count of serious crimes 
per tract in summer 2008. Call the output CrimeAggregatedByTracts. Use the results to symbolize 
PghTracts centroids with size-graduated point markers. Hint : Use Quantities, Graduated symbols 
for symbolizing the crime count (there is no need to create tract centroids in this case). 

Set threshold scales so that when zoomed in to about a fourth of Pittsburgh or farther, 
PittsburghSeriousCrimesSummer2008 turns on and CrimeAggregatedByTracts turns off. 

Create a layout of your own design for the map document, zoomed to full extent. 

Analyze the data 
Get set up to create a graph: 

• Open the CrimeAggregatedByTracts property table, click the Fields tab, and give Count_ 
~ 

the alias Serious Crimes. 

• Open the PghPovertyTracts table and give PopBelowPovLevel the alias Population Below 
Poverty Level. 

• Join PittsburghPovertyTracts to CrimeAggregatedByTracts. 

Create a scatterplot of Serious Crimes versus Population Below Poverty Level: 

• Use View > Graphs > Create Graph to create the scatterplot. 

• Once created, resize its window so that the vertical and horizontal axes are the same 
length. 

• Right-dick the graph and click Copy As Graphic. On your layout, click Edit > Paste. 
Reposition and align the graph and other elements of your layout. 

• Save your layout and export it as Assignment4-2YourName.jpg. 
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